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Synchronize macOS Filevault password after a password reset

As of agent 0.9.583, the agent has Filevault Support for password synchronization.

This document assumes that the the user has already been added to the Filevault configuration. If not, see JumpCloud provisioned users do not appear on Filevault login screen after power cycle​.

Symptoms

On macOS, after a password reset and subsequent power cycle using a JumpCloud managed user, the login screen does not accept the new password to decrypt the disk.

Cause

Filevault is not currently managed by the JumpCloud agent. MacOS maintains three passwords:
  • Filevault (for disk encryption)
  • Keychain (for saving certificates, passwords, etc..)
  • User password (the final login prior to getting to the desktop)
When all passwords are sync'ed, logging in once at Filevault will automatically log into keychain and user to get to the desktop. If they aren't sync'ed, then it will prompt for each.

Solution
  1. Decrypt the disk using the previous password.
  2. At the user login, use the new password.  
  3. Once logged in, synchronize all passwords.  Go to System Preferences > Users & Groups
  4. Select your account, then select Change Password...
  5. Enter the new password for all fields. This will synchronize all passwords to the new user password.
 

Last Updated: Apr 07, 2017 02:14PM MDT

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