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After a password reset on Mac subsequent login results in "The system was unable to unlock your local items keychain"

Symptoms

After resetting a JumpCloud password where the user is bound to an Mac system, on the next login, the system prompts with "The system was unable to unlock your local items keychain"

Cause
  • Prior to agent version 0.9.587, the login process did not synchronize the local items keychain password.  
  • If the system was offline when a user reset their password and the login screen is presented prior to getting internet access for the agent to synchronize the password change.
  • If fast user switching is enabled and was used to login subsequent to the password reset
  • If the previous keychain password is not entered on the login screen


Solution

Make sure the agent has been updated to version 0.9.587.

If this was caused by any other of the conditions, there are three options on the dialog box:
  • Continue Login
  • Create New Keychain
  • Update Keychain Password
It is recommended to select 'Update Keychain Password' so that stored credentials for other applications in the current keychain will remain accessible. Selecting this option will prompt for the current keychain password, which will be the previous JumpCloud password. If the previous password is unknown, a new keychain may need to be created. The keychain access app can also be used to manage keychains if necessary.  
 

Last Updated: Jun 01, 2017 12:21PM MDT

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